Using Earthscope and B4 LiDAR data to analyze Southern California’s active faults
A joint SCEC/OpenTopography/USGS/UNAVCO research and education workshop

Exercise 2: Basic visualization of LiDAR Digital Elevation Models using
ArcGIS

Introduction

This exercise covers activities associated with basic visualization of LiDAR Digital Elevation
Models using ArcGIS. Topics include a description of the standard tiled DEMs available from
http://www.opentopography.org, loading them into ArcMap and mosaicking them, and producing
color gradient maps, hillshades, slope maps and slopeshades, and contour maps.

Data included

We start with the uncompressed downloaded archives from http://www.opentopography.org ->
Standard DEMs.

The DEMs in this example are for Sanborn Park area in the Santa Cruz Mountains, California
(archive names are 583 4120, 583 4121, 582 4120 and 582 4121).

Data Data Resolution Coordinate System
format (m)
GeoEarthScope Lidar data ArcGrid 0.5 UTM Zone 10N, WGS84
tiles—unfiltered (all the data) ellipsoid heights

and filtered (just ground
returns) interpolated by kriging
to make DEM. Includes
hillshades

Data source, type, and file naming convention

OpenTopography delivers the Standard DEMs as delivered from the National Center for Airborne
Laser Mapping (http://www.ncalm.org/). In this demonstration, we will play with the filtered and
unfiltered 1km x 1km ArcInfo grids @ 0.5m cell size and their shaded relief maps (NO overlap).

Due to ArcInfo file naming limitations, the grids contain only the significant digits from the lower
left coordinate of their originating tile. For example, the ASCII tile named
“£571000_4130000.xyz” corresponds to the ArcInfo elevation grid named “fg571 4130 and
shaded relief map “fg571 4130shd”. Filtered elevation grids are prefixed by “fg” and the
hillshades end in “shd”. Unfiltered elevation grids are prefixed by “ug” and the hillshades end in
“shd.”

ArcGIS activities

Introduction

The ArcGIS software suite has many useful capabilities for handling geospatial data including
LiDAR DEMs. We use ArcMap 9.3 (with its extensions Spatial Analyst and 3D Analyst) to
produce map view visualizations. For some introductory lessons in ArcGIS, you should check the
ESRI web sites (http://www.esri.com/ and http://www.esri.com/what-is-gis/index.html) and you
may also try Ramon’s lectures at http://arrowsmith410-598.asu.edu/GLG410_598--Lectures.html.
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Launch ArcMap and load data

Under the Start Menu, navigate to ArcGIS and launch ArcMap. Once the software is launched,
you can click on the yellow plus to add the DEMs:

% Untitled - ArcMap - Ardnfo

File Edit View Bookmarks Insert Selection Tools Window Help

= = (= A S & O N

=] Layers T

Note that the first time you navigate for the data, you may need to “Connect to the folder”
and navigate to where they are located:

Add Data (o)
Lookin: | @ Catalog | a| cplsele| [ mlas|
BC!\ @g GIS Serve|Connect To Folder

Mosaicking the DEM tiles

Before adding too many files, let’s mosaic the 4 contiguous square kilometer tiles that we

downloaded. For this, you need to open up the ArcToolbox (red toolbox symbol):
% Untitled - ArcMap - Ardnfo

File Edit View Bookmarks Insert Selection Tools Window Help

DeE& (= A S & O N

=] Layers
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% Untitled - ArcMap - Arcinfo

File Edit View Bookmarks Insert Selection Tools Window Help

DEeE& BX | > & | &$ O

x. x.

m =-&p Data Management Tools -

@ Data Comparison

@ Database

@ Disconnected Editing

@ Distributed Geodatabase

@ Domains

@ Feature Class

@ Features

& Fields

@ File Geodatabase

@ General

5 Generalization

@ Indexes

@ Joins

@ Layers and Table Views

@ Projections and Transformatior:

= @ Raster

@ Raster Catalog
=] @ Raster Dataset

# Copy Raster
#* Create Random Raster
A Create Raster Dataset
#* Mosaic m

37 Mosaic To New Raster

Y= Mosaic To New Raster

Input Rasters

Output Location

C:\Users\ramon\Desktop\temp\Projects\SCEC \Workshop \Exercise 2Tutorial \582_4120...
C:\Users\ramon\Desktop\temp\Projects\SCEC\Workshop \Exercise ZTutorial\582_4121...
C:\Users\ramon\Desktop\temp\Projects\SCEC \Workshop \Exercise ZTutorial\583_4120...
C:\Users\ramon\Desktop\temp\Projects\SCEC\Workshop \Exercise ZTutorial\583_4121...

| C:\Users\ramon\Desktop\temp\Projects\SCEC \Workshop \Exercise ZTutorial
Raster dataset name with extension

[ [ [X |+ &

%

| fullmos
Coordinate system for the raster (optional)

http://www.opentopography.org

I WGS_1984_UTM_Zone_10N
Pixel type (optional)

[ 32_BIT_FLOAT |
Cellsize (optional)
Number of bands

1

Mosaic Method (optional)
| LasT =~
Mosaic Colormap Mode (optional)

FIRST LI

Open the toolboxes: Data Management
Tools->Raster->Raster Dataset-
>Mosaic to New Raster.

* Select the files to be mosaicked by
clicking the open folder at the upper
right and progressively select them.

* The Output Location is a directory
(folder) into which the mosaic will go.
* Provide a mosaic name.

* The coordinate system can be
defined by clicking the small button

(=) and either Selecting by

choosing the coordinate system into
which you want the mosaic projected,
or Importing which will pull the
projection from an existing file (in this
case, [ used one of the DEM tiles) if
you navigate to the file and select it.

* The Pixel Type should be 32 bit
float.

* The other boxes can be left
optional.

* Click OK to launch the mosaicking
process and after a few seconds to
minutes, you will have your mosaic
added to the ArcMap project. Mosaic
both the full feature and the bare earth
DEMs.
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How to visualize the DEM

Color gradients

To visualize the

File Edit View Bookmarks Insert Selection Tools Window Help

topography color coded by
elevation (with a different

<& Zoom To Layer

"@ Zoom To Raster Resolution
Visible Scale Range »

Data

Save As Layer File...

DEzE&E BB X | o o | g |[rzan ST 1=
3 x‘
= £F layers ‘
B Im W
Copy
X Remove
E
bar Joins and Relates »

|

color ramp than the default
grayscale), right click on
the DEM file name in the
Table of Contents (left
portion of the ArcMap
window) and choose
Properties.

®  Untitled - ArcMap - Arcinfo

File Edit View Bookmarks Insert Selection Iools Window Help

Choose the symbology tab
- and select the color ramp of

DESEE& L 2R X v | $||[tEa v |2 & @ 0 3= N2 | Editrv| > | £~
x

= £ layers

= @ [

Value
High : 798.241

Low: 280361
® baremos

interest
Layer Properties ﬂﬂ

General | Source | Bxtent | Display Symbology | Felds | Joins & Relates |

Show:
[Draw raster ing values along a color ramp Import...

Color Value Label

H 798.241394  [righ : 798.241

2036140 [low:280.361

n,

™ Invert

- . —

Co |

Cancel

http://www.opentopography.org
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Hillshade

Hillshades are a commonly used visualization of topography. They are a simulated reflection of a
light source of specified azimuth and zenith angles from the topography (with set reflective

properties) toward the viewer who is looking straight down.

Untitled - ArcMap - Ardnfo

’ File Edit |View Bookmarks Insert Selection Tools Window Help

T 1=-Fcan

D & 1@ DataView 'A | & |[113411 =~
—_— Layout View
= £ Lay Zoom Data >
S| Zoom Layout >
Toolbars » -
[v Status Bar Georeferencing
Overflow Annotation Geostatistical Analyst
= .
* G Scrollbars Graphics
@& Rulers Labeling
;,‘f_ S | v Layout
E 6 Map Cache
' Network Analyst
Data Frame Properties... L
Parcel Construction
Publisher

Raster Painting
Representation

Route Editing

Schematic

Schematic Editor
Schematic Network Analyst
Spatial Adjustment

Spatial Analyst

j Standard

http://www.opentopography.org

To produce the hillshade,
you first may need to
display the Spatial Analyst
toolbar (View->Toolbars)

Page 5



Using Earthscope and B4 LiDAR data to analyze Southern California’s active faults
A joint SCEC/OpenTopography/USGS/UNAVCO research and education workshop

In Spatial Analyst, select Surface

i L 4 - |full
‘ SRl ’ e Iu — = Analysis->Hillshade

Distance >

Density...
Interpolate to Raster >

| Cell Statistics... Slope...
Neighborhood Statistics... Aspect...
Zonal Statistics...
Zonal Histogram ... Viewshed...
Reclassify... Cut/Fill...

Raster Calculator...

Convert

Options...

In the Hillshade dialogue box:
* define the input surface (one of
your DEMs)
Input surface: |fullmos e select the azimuth (315 is default,
but try 45 for some variety as
| 315 well)
I 45 * specify the altitude (this is the
zenith angle from vertical for the
simulated light source)
* Choose Model Shadows (this does
7 factor: I 1 a fancier computation which can
be annoying at times in LIDAR
Output cell size: I 0.5 data with small and tall features).
Experiment with this checked and
Output raster: | C:\Users\yamon\Desktop\teme | G5 not.
* We don’t usually change the Z
oK Cancel factor or output cell size.
* Provide a file name to make the
hillshade permanent

Hillshade IREECS
= =

Azimuth:

Altitude:

[V Model shadows
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Combine color gradient and hillshade into a map
A nice visualization combines the colored elevations semi-transparently over the hillshade.
Make sure that the hillshade is underneath the colored dem (both were produced in the last two

steps).

( Layer Properties @Iﬁ nght click on the DEM
file name in the Table of
Contents (left portion of the

General | Sourcel Extent Display ISymbology] Fields I Joins & Relates |

[~ Show Map Tips (uses primary display field)

[~ Display raster resolution in table of contents ArCMap WlndOW) and
[~ Allow interactive display for Effects toolbar ChOOSe Properties . Select
Resample during display using: the Dlsplay tab and type 25
INearest Neighbor (for discrete data) L’ or 50% (dO some
Contrast: o « '_F O experimenting) in the
Brightness: o % | ~ e ] transparency box and click
Transparency: 50 % ok.

Display Quality :

isplay Quali R

Coarse  Medium Normal |_

ok | cancel | poply

Switch from the data view to layout view by clicking the small piece of paper shaped button at the

an/e-uLl_

1] A~ |‘ Layout View
lower right of the table of contents in ArcMap:
You now will see your view of the map as it would appear on a piece of paper once prlnted
Move the view around with the hand tool and zoom (Tools toolbar).

Add a north arrow (Menu->Insert->North Arrow). Move it and resize it as desired.

Add a scale bar (Menu->Insert->Scale bar [click on properties to change the units if necessary]).
Move it and resize it as desired.

Add a text box and other annotation using the Drawing toolbar.
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Legend Wizard @ Adda legend
(explanation): (Menu-
Choose which layers you want to include in your legend | >Insert->Le gend). Use the
Map Layers: Legend ltems

left pointing arrow to move

Emz;h ; > 7| all the layers except the
- baremos > DEM out of the Legend
1, Items column. Click Next.

Set the number of columns in your legend: |1 _%'

Preview |

Bach Net> |  Cancel |
Legend Wizard =) Rename it to Elevation (m).
Click Next.
— Legend Title
Elevation (m)
~ Legend Title font properties ———— [~ Title Justification

v

EE . You can use this to

control the justification
Size: |15 - of the title with the rest
of the legend.

Font: |\o] Avial |

" 2| al = ===
Preview

< Back Next > Cancel |

Click through the rest of the screens, leaving the defaults and finish.
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Now you have an Explanation/Legend, but it should be cleaned up:

Right click on the Legend and choose Properties. Then click Style at the right of Legend
Properties dialogue and then Properties in the Legend Item Selector. Turn off Show Layer Name

and Show Heading in appearance. Click OK back through the dialoguels.
N L =

-
3o

"LI

http://www.opentopography.org

=

IS f [
Legend Properties
= = Legend Item Selector M
Legend ltems | Frame | Size and Posttion | " Preview
-~ Spedify Legend Items saacing Legend 7 i
Map Layers: Legend Items: | Vd:ens
+ fullmos LI ll il & - Description B Hioh 798241
- fullmosshd Horizontal Bar with Heading,  Horizontal Single Symbol
" baremos 2] il il Labels, and Description Description = B Low :280.381
Legend i
iI I Placei Layer Name
e [ Qe B Description
il Columns: I—- Horizontal Single Symbol Horizontal Single Symbol
Label Only Layer Name and Description
Ch text
e Legend Item M
@ alitems " Selected item(s)
IAppIy to the whole item ;I
~Map Connection ¥ Show Labels
¥ Only display layers that are checked on in the Table Of Conter Label Symbol... |
|V Add a new item to the legend when a new layer is added to
[V Reorder the legend items when the map layers are reordered [~ Shgw Heading I~ Show Descriptions
[” Scale symbols when a reference scale is set Heading Symbol Description Symbol
I Ovenide default patch I Ovenide default patch size
LI — Line: I vl Width: |36 pt

Height: |24 pt

Only show classes from this heading: IVaIue

[~ Prevent item from being splt across legend columns

[ ox 1]

Cancel |
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We are getting there . To finish off the labeling more cleanly, now go
back to the Table of Contents in the left side of the main ArcMap Window and right click on the
DEM and choose Properties and then the Symbology tab. Edit the labels to be more appropriate.

e " W =)
General | Source | Extent | Display Symbology | Fields | Joins & Relates |
Show:
Uni‘:ue Values Praw raster stretching values along a color ramp Import...
Classified
Stretched it

Color

m

Type: IStandard Deviations Zl Histograms. ..

n: I 2 [~ Invert

| ok | cancel | Ay |
Export the map as a PDF file if desired for other documents.

The final map showing the bare earth dataset with the
San Andreas Fault trace clearly cutting from upper
left to lower right..

0 125 250 500 Meters Sanborn Park
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Slope and slopeshade

Computing the local slope of the DEM is done similarly as hillshade and contours: Spatial

Analyst->Surface Analysis->Slope. Check that the input surface is correct. Usually we compute

slope in Degrees. Don’t change the Z factor or Output cell size. Give the Output raster an

appropriate name and save it with related files.

|Spatia| Analyst " Layer: [fulmos

Distance 4
Density...
Interpolate to Raster »
Surface Analysis > Contour... Slope =
Cell Statistics... m ||| Inputsurface: Ibarernos LI EI
Neighborhood Statistics... Aspect.. -
Zonal Statistics... Hillshade... Output measirement: ozt o
Zonal Histogram ... Viewshed... Z factor: I 1
. Cut/Fill...
Reclassify... Output cell size: I 0.5
Raster Calculator... TR IC:\UsersVamon\Desktnp\temp

Convert >

Options...

OK | Cancel |

The default green to orange color ramp shows the slope distribution well.

File Edit View Bookmarks Insert Selection Tools Window Help

DEES| ) 2@x |0~

g A
= £F layers
= O [ i

= M baremosslp
[ 0.001382333 - 8.137945658
[ 8.137945659 - 15.33567475
[115.33567476 - 22.22045911
[[122.22045912 - 28.16640923
[]28.16640924 - 33.17352512
[[7133.17352513 - 3818064101
[ 38.18064102 - 43.50070165
[ 43.50070166 - 51.01137549
[ 51.0113755 - 79.80229187

O fullmos

O fullmosshd

baremos

O baremosshd

http://www.opentopography.org

& |[17.065 -l |8
g

X 1=R3

Spatial Analyst " Layer: I\‘ullmos
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Visualizing the landscape as a “slopeshade” can be useful. Your brain treats it similarly as it does
a hillshade, except here it looks as if the illumination comes from all directions. The slopeshade
simply takes the slope map and colors it with steep slopes dark and low slopes white (black to
white inverted color ramp) and stretches the range nonlinearly. Right click on the slope map and

Compute Unique Values

( )
& values?

@Y Unique histogram does not exist. Do you want to compute unique

Click yes.

An error message about there being too many values may pop up. Click ok. In the Layer

choose Properties. You may get request to compute unique values
[

Properties, click the Symbology tab. Choose Stretched for what to Show and then choose a color
ramp that goes black to white with the high slopes being white. Choose “Standard Deviations” -
typically we start with n=5 (default is n=2), but a range of values work depending on what you
want to emphasize. You can also tweak the curve on the histogram page to pull out details in
certain ranges of slope values.

Layer Properties

Show:

Genefall Sounce] Exlentl Display Symbology Iﬁelds I Joins & Relates

Unigue Values
Classified
Stretched

‘Draw raster stretching values along a color ramp Import...
Color Value Label
79.802292  [High : 79.8023
0.001382 |y 0w :0.00138233
corrore: | =
|~ Display Background Value: 0 as |~

I Use hilshade effect 7. |1 Display NoData as |+

Stretch
|( Type:

[V Invert

| »

oK I Cancel

Apply

http://www.opentopography.org
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Contours
Use Spatial Analyst to compute contours from one of your DEMs: Surface Analysis->Contour.

In the Contour dialogue box (below right), make sure you choose the correct input surface.
Specify the desired contour interval. The base contour should be 0 and keep the Z factor 1. The
process will produce an Arc shapefile. You should save it in the same directory as your other
DEM data.

Contour EE
Input surface: Ibaremos LI EI
‘ Spatial Analyst ¥ ‘ Layer: lfullmos > || [ Contour definition
3 Distance > | 5 |6 Input height range: Zmin: 281.202728 Zmax: 762.3¢
Density... Contour interval: I 10
g Interpolate to Raster 14 FEsnErTTE | 0
Surface A i » -
Cell Statistics... Slope...
Neighborhood Statistics Aspect... r~Output information based on input contour definition
Zonal Statistics... Hillshade... Minimum contour: 290
Zonal Histogram ... Viewshed... Maximum contour: 760
Reclassify... Cut/Fill.. Total number of contour values: 43
Raster Calculator...
Output features: C:\Users\ramon\AppData\Locz El
! Convert >
4

OK | Cancel I

Options...

To label the contours, right click on the contours shapefile and select Label Features. Usually, the
contours will first be labeled by the feature number and not the elevation. To change the labeling
to elevation, right click on the shapefile and click Properties. Select the Labels tab. Change the
Label field to CONTOURS. Change other characteristics of the label display while you are there
as well. For example, under Placement Properties, you can move the labels onto the contour lines.
o AL . R TIAIR T AT

Layer Properties { 1y = A 7y {f
‘ LAY

Genemll Souncel Seiectionl Displayl Symbologyl Fields I Definition Query  Labels |Joins&Re|ates| HTML Popupl ’, \ g y
[V Label features in this layer i
Method: | Label all the features the same way. ;I

All features will be labeled using the options specified.
~ Text String
Label Field: D
L [FD
~ Text Symbol ———{
AaBbYyZz
H- B|1|g| Symbol... |
~Other Options Pre-defined Label Style
Placement Properties... Scale Range... | ’7 Label Styles... |
OK | Cancel Apply
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