TUTORIAL:
Batch Downloading of LIDAR DEM Data via the OpenTopography Portal
Christopher Crosby (ccrosby@sdsc.edu)

Last updated: July 16, 2009

INTRODUCTION:

This tutorial is designed to aid OpenTopography Portal users who wish to make
bulk downloads of LiDAR DEM tiles via the interface located at:
http://opentopo.sdsc.edu/gridsphere/gridsphere?cid=bulkd]l

The batch download capability of the OpenTopography Portal is designed for
advanced users seeking to download large amounts of data quickly and who have
the bandwidth, expertise, and software necessary to manage the gigabytes of data
this method delivers. For most users we recommend the Google Map-based tile
download interface found in the Portal at: http://opentopography.org/dems

METHOD:

The OpenTopography Portal provides batch download capability for datasets where
standard Digital Elevation Models are available. Under each dataset is a list of
specific "targets" or acquisition areas. Clicking on the target link loads a page that
lists referring URLs for all available 1km? DEM tiles for a data set on a single page to
facilitate easy batch downloading. It is up to users to choose a method to retrieve
these data in bulk. This tutorial provides a basic introduction to free software
options to retrieve these data. A Google search for “download manager” will quickly
reveal alternative options if the ones below do not work for you.

We recommend and will highlight the following download managers in this tutorial:

I. DownThemAll! extension for the Firefox browser
(http://www.downthemall.net/)

I1. Free Download Manager (http://www.freedownloadmanager.org/)

For users who are comfortable with commandline utilities, batch downloading of
the tile DEMs can also be easily accomplished via the free GNU Wget program
(http://www.gnu.org/software /wget/).

Please address questions or comments on the OpenTopography Portal batch

download capability to info@opentopography.org



I. DownThemAll!

DownThemAll! (http://www.downthemall.net/) is a popular and free download
manager for the Firefox web browser. Once you’ve installed DownThemAll! (dTa),
use the following steps to download data from OpenTopography:

From the batch downloads page
(http://opentopo.sdsc.edu/gridsphere/gridsphere?cid=bulkdl)
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Batch Downloads of LIDAR DEM Tiles

This page is designed to aid OpenTopography Portal users who wish to make bulk downloads of DEM tiles. It is designed for advanced
users seeking to download large amounts of data quickly and who have the bandwidth, expertise, and software necessary to manage the
gigabytes of data this method delivers. For most users we recommend the Google Map-based tile download interface found under the
Standard DEMs link located under the Data tab,

Below are a list of OpenTopography hosted datasets for which standard DEMs are available. Under each dataset are a list of specific
“targets" or acquisition areas. Clicking on the target link loads a page which lists referring URLs for all available 1km? Digital Elevation
Model (DEM) tiles for a data set on a single page to facilitate easy batch downloading. Each url returns a .zip file that contains bare earth
(ground) and unfiltered {all returns) DEMs. You can download the tiles one-by-one or by using your favorite download manager program.
We recommend the DownThemalll extension for the Firefox browser, waget, or the Free Download Manager, For more information please
see our batch download tutorial,

Datasets:

% Intermountain Seismic Belt (ISB) GeoEarthScope:
Elephant Plateau (361 files, 8.8 GB)
Mallard (126 files, 2.5 GB)

— = .6 GB)
Teton (129 f||es 2.3 GB)
Wasatch fault Nephi South (108 files, 2.2 GB)

< Southern & Eastern California GeoEarthScope:
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Clicking a “target” (i.e. a data set subset) link such as the “Old Faithful” portion of the
Intermountain Seismic Belt GeoEarthScope dataset loads a page that lists referring
URLs for all available 1 km? Digital Elevation Model (DEM) tiles for a data set on a
single page to facilitate easy batch downloading.



Each URL on the page below returns a .zip file that contains bare earth (ground) and
unfiltered (all returns) DEMs. You could download the tiles one-by-one, but a
download manager program can pull them all with minimal work on your part.
Note that each page lists the # of files and the total data volume you are going to get
back.
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Batch download of OpenTopography LiDAR tiles

This page lists referring URLs for all available Digital Elevation Model (DEM) tiles for a data set on a single page to facilitate easy batch downloading. You can
download the tiles one-by-one or by using your favorite download manager program. For more information please see our batch download tutorial . This page
is designed for advanced users seeking to download large amounts of data quickly. For most users we recommend the Google Map-based tile download

interface available at: http:/fwwnw opentopography. org/dems

Project: GeoEarthScope Intermountain Seismic Belt
Target: OLD_Faithful 08_195

Coordinate System: WGS 1984 UTM Zone 12N
Number of zip files: 94

Total size: 2.0 GB

Grid URLs:

Each utl returns a less than 30 MB ZIP file containing filtered ("bare earth", fg*) and unfiltered (ug*)
DEMSs in ESRI Arc Binary grid format

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4931 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4931000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4932 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4932000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4933 OLD Faithful 08 195.zip (tie lower left x: 509000 y: 4933000)

http://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4934 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4934000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4918 OLD Faithful 08 195.zip (tie lower left x: 510000 y: 4918000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4919 OLD Faithful 08 195.zip (tie lower left x: 510000 y: 4919000)

http://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4920 OLD Faithful 08 195.zip (tile lower left x: 510000 y: 4920000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4921 OLD Faithful 08 195.zip (tile lower left x 510000 y: 4921000)

Above is the page you’ll want to run the download manager to sequentially
download all of the URLs listed on the page.



IMPORTANT: Before you run dTa to download the files, we recommend you make a
change to the default settings of the program. Navigate to “Tools” menu in Firefox >
“DownThemAll! Tools” > “Preferences” and select the “Advanced” tab. On the
“Advanced” tab you’ll want to disable “Multipart Download” by moving the slider
bar all the way to the left until the dialog reads “1 / Disabled”. This change seems to
lead to fewer failures during download.

% DownilhemAll Preferences... @

el % & & @

Main Filters  Privacy  Interface  Advanced

Multipart download
Max. number of segments per download: Q 1 / Disabled

Download timeout

Download timeout after S minutes v

Miscellaneous settings
Set file time to last modified time {server) or time of queuing
[T] Have dTa Oneclick remember if it applies to all Tabs or Current Tab

User must confirm removal of downloads

Load last Few kilobytes First J

Temporary files

[] save download segments in a kemporary directory
Use this directory: E)

Restaore default settings [ QK ] [ Cancel




Once you’ve modified the preferences of dTa as noted above, navigate back to
“Tools” > “DownThemAll! Tools” > but this time select “DownThemAll!...” Doing so
loads a the dTa dialog that looks like this:

% Downlhemall! - Make your, selection

é Links (99) @ Pictures and Embedded (3) DOUJ'\/\HEM All !
URL Description Renaming mask B
=) hitp:{ fwwww.earthscope. orgf Default a5
@ http:fwww,opentopography.orgf Default
@] http: fjwww . geonarid.orgf Default
\:1] http: fjwww, opentopography . orgfindex. php/resources/tutorials batch download tutorial Default
@ http:fjwww . opentopography.org/dems http:/fwww.opentopograp... Default

@ @http:.f,fcordillera.Ia.asu.edu;‘ISBIISBMapServlet_Link?mapid=509_... http:ficordilera.la.asu.edu... Default
@ @]http:,f!cordillera.Ia.asu.edu;‘ISBIISBMapServlet_Link?mapid=509_... http:ficordilera.la.asu.edu... Default
@ @]http:f,fcordillera.Ia.asu.edu;‘ISB,fISBMapServlet_Link?mapid=509_... http:f/cordilera.la.asu.edu... Default
@ @http:.n',fcordillera.la.asu.edu;‘ISB,fISBMapServlet_Link?mapid=509_... http:f/cordilera.la.asu.edu... Default
@ @http:.f,fcordillera.Ia.asu.edu;‘ISBIISBMapServlet_Link?mapid=51Cl_... http:ficordilera.la.asu.edu... Default
@ @]http:ﬁcordillera.Ia.asu.edquSBIISBMapServlet_Link?mapid=51L'l_... http:ficordilera.la.asu.edu... Default

R ~
@ @] http:ficordilera.la.asu.edufISB/ISBMapServlet_Link?mapid=510_... http:f/cordillera.la.asu.edu... Default .
_Savefites: Renaming mask:
< C:\Documents and SettingsiChristopher Crosby|Desktopitest), ame™ , *ext* v | 8 %,

\

-I Filters
[] Allfiles archives (zip, rar, ...)

[] 1mages (jpg, pna, ...} [ IPEG Images

[] audio (mp3, way, ...) [] software {exe, xpi, ...)
[] videos (mpeaq, avi, ...)

- Fast filtering
v [] Disable ather filters
[ Start! ] [Add paused ] [ Cancel
Selected links: 94 of 99 ~ Preferences

dTa will recognize every link on the page but since all we want are URLs that point
to “.zip” files, we select only the “Archives (zip, rar,...)” filter option and leave all
other boxes unchecked.

In the “Save files in:” box, define where you want to put the downloads.

Once you’ve got everything set, click “Start!”



Once dTa starts running you get a dialog box that shows the status of the
downloads. Depending upon the number of files, server load, and your bandwidth,
it may take a while for the downloads to complete.

% 40% - 38194 - 7.31 MB/s - DownlhemAll!

©O 00 0 0 60O .
Add URL{(s) Resume Cancel Top Up Down  Bottom DONATE HERE! ;
URL/MName Progress Completion Size Est. time Speed B
D s11_49202p O 100% 27.79 MB Complete &
@ 511_4921.zip © 100% 27.68 MB Complete
@ S511_4922.zip © 100% 28.16 MB Complete
€3 511_4923.2ip © 100% 26.08 MB Complete
€3 511_4924.2ip © 100% 26.00 MB Complete
@ 511_4925.zip © I 100% 24,99 MB Complete
@ 511_4926.zip © I,  100%, 26.21 MB Complete
@ 511_4927.zip © I, 100%, 28.21 MB Complete
@ 511_4928.zip © I, 100%, 28.48 MB Complete
€3 511_4930.2ip L 100% 24,62 MB Complete
@ 511_4931.zip i) . r———————————————— 11 R (113 22,19 MB Complete
@ 511_4932.zip O I 100% 22,76 MB Complete
@ 511_4933.zip O I,  100% 24,03 MB Complete
@ 511_4934.zip O I 100% 23.27 MB Complete
@ 511_4935.zip O 100 9,80 MB Complete
@ 511_4936.zip . ] 100% 9.59 MB Complete
@ 512_4918.zip i 100% 22,27 MB of ... 00:03
@ 512_4919.zip 475 79% 20,07 MB of ... 00:07 1.38 MBfs
@ 512_4920.zip & 1% 19.91 MB of ... 00:07 1.72 MBfs
@I 15BMap5...et_Link 0% Unknown Waiting
@I 15BMap5...et_Link 0% Unknown Waiting
@I 15BMap5...et_Link 0% Unknown Waiting
@ 1SBMap5...et_Link 0% Unknown Waiting
=) 15BMaps... et _Link 0% Unknown Waiting
=) 15BMaps... et _Link 0% Unknown Waiting
@ 1SBMapS...et_Link 0% Unknown Waiting
@ 1SBMap5...et_Link 0% Unknown Waiting o
@ 1SBMap5...et_Link 0% Unknown Waiting v
Complete downloads: 38 of 94 - Current speed: 7.31 MBfs ' Preferences !

In some cases, a download will hang up - for example the yellow bar in the example
above listed as a “Server error”. In this case you can select that file and click on the
“resume” button at the top to restart the download. If you have a few failed
downloads, you can right click in the dTa box and select “Remove completed tasks”
to remove the files that succeeded. Then, select all of the remaining files and restart
them.



II. Free Download Manager

The Free Download Manager (http://www.freedownloadmanager.org/) is a free-

standing application that is a good option for users who do not use the Firefox
browser and therefore can’t use DownThemAll!l. FDM is a windows only application.

Once you've downloaded and installed FDM, follow the first two steps of the
DownThemAll! tutorial above to get to the webpage that lists the referring URLs for
the DEM tiles for a given dataset:

) GeoFarthScope Intermountain Seismic Belt - Mozilla Firefox
File Edit View History Bookmarks Tools Help
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Batch download of OpenTopography LiDAR tiles

This page lists referring URLs for all available Digital Elevation Model (DEM) tiles for a data set on a single page to facilitate easy batch downloading. You can
download the tiles one-by-one or by using your favorite download manager program. For more information please see our batch download tutorial . This page
is designed for advanced users seeking to download large amounts of data quickly. For most users we recommend the Google Map-based tile download
interface available at: http:/fwanw opentopography. org/dems

Project: GeoEarthScope Intermountain Seismic Belt
Target: OLD_Faithful 08_195

Coordinate System: WGS 1984 UTM Zone 12N
Number of zip files: 94

Total size: 2.0 GB

Grid URLs:

Each utl returns a less than 30 MB ZIP file containing filtered ("bare earth", fg*) and unfiltered (ug*)
DEMs in ESRI Arc Binary grid format

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4931 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4931000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4932 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4932000)

http:/fcordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4933 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4933000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509 4934 OLD Faithful 08 195.zip (tile lower left x: 509000 y: 4934000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4918 OLD Faithful 08 195.zip (tie lower left x: 510000 y: 4913000)

http:ficordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4919 OLD Faithful 08 195.zip (tile lower left x: 510000 y: 4919000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4920 OLD Faithful 08 195.zip (tile lower left x: 510000 y: 4920000)

hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510 4921 OLD Faithful 08 195.zip (tie lower left x: 510000 y: 4921000)




The Free Download Manager interface looks similar to the dTa interface discussed
above but functions slightly differently since it is not embedded in the browser.

EBX

8 Free Download Managern
File View Downloads Options Tools Help
= 2 /2 — [ \ (@ oA
D QPO UGB e O
VO ®W 3l & &Y G :
Downloads | Flash video downloads | Torrents | >3
¥ Mot completed+Recen  File name Size Downloaded Timer... Sections Speed
-1 All downloads
W Music
¥ Other
¥ Software
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+ Complete
# In progress
W Stopped
[ scheduled
+ _| History
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Comment Added
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FDM has lots of options, but for the sake of this simple tutorial, we will stick with the
basics. First, it will place downloaded files in C:\Downloads\ by default - to change
the default download directory click on “Options” > “Settings” > then select “New
Download” from the “Downloads” menu and click the “Set default download folder”.



Since FDM is not part of the browser, it doesn’t discover the URLs on the page the
same way that dTa does. The simplest way to provide FDM a list of URLs to
download is to click and drag to select all of the URLs on the download page like

this:

2) GeoEarthScope Intermountain Seismic Belt - Mozilla Firefox

Coordinate System: WGS 1984 UTM Zone 12N
Number of zip files: 94

Total size: 2.0 GB

Grid URLs:

Each utl retumns a less than 30 MB ZIP file containing filtered ("bare earth", fg*) and unfiltered (ug*)
DEMs in ESRI Arc Binary grid format

http:/fcordillera la asu edw/ISB/ISBMapServlet Link?mapid=509 4931 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=509_4932_OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=509_4933 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la. asu. edwISB/ISBMapServlet Link?mapid=509_4934 OLD_Faithful 08 _195.zip (tile lower left x
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4918 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4919 OLD_Faithful 08 _195.zip (tile lower left x:
hitp://cordillera la asu. edw/ISB/ISBMapServlet Link?mapid=510_4920_OLD_Faithful 08 _195.zip (tile lower left x:
http:/fcordillera la asu edw/ISB/ISBMapServlet Link?mapid=510 4921 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4922_OLD_Faithful 08_195.zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4923 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4924 OLD_Faithful 08_195.zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4925 OLD_Faithful 08 _195.zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4926_OLD_Faithful 08 _195.zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4927 OLD_Faithful 08 195 zip (tile lower left x:
hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4928 OLD_Faithful 08 _195.zip (tile lower left x

hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_4929 OLD_Faithful 08 _195.zip (tile lower left x:

hitp://cordillera la asu. edwISB/ISBMapServlet Link?mapid=510_ 4930 _OLD_Faithful 08 _195.zip (tile lower left x:

File Edit View History Bookmarks Tools Help
- C o U] httpffcordillera.la, asu.edu/1SB/BUTIEDL_OLD_Faithful_08_195.html 760 - 9
'a OpenTopography Portal x] ﬂ GeoEarthScope Intermountain S... ﬁ ‘ +

509000 v: 4931000)

509000 v: 4932000)
509000 v: 4933000)
09000 y: 4934000)
510000 v: 4913000)
510000 v: 4919000)
510000 v: 4920000)
510000 v: 4921000)
510000 v: 4922000)
510000 v: 4923000)
510000 v: 4924000)
510000 v: 4925000)
510000 v: 4926000)
510000 v: 4927000)
510000 v: 4928000)
510000 v: 4929000)

510000 y: 4930000)

Once the URLs have been selected, copy them (control + C) then go to the FDM
interface and select “File” > “Import” > “Import list of URLs from clipboard”. You
will be prompted to “Select a Group”, leave the default and click OK.



Like dTa, FDM will display status of each download as it runs:

'@7 Download Manager ‘B“E(@
File View Downloads Options Tools Help
0000 PV UuA QR 00
Downloads | Flash video downloads | Torrents | >3
# Mot completed+Recen  File name Size Downloaded Timer... Sections Speed Comment Added ~
=21 Alldownloads (34) | o 510 4924(1).2p 20,6 MB  100% [20.6 MB) 0f15 7{16/20
: 2;::. - ¥ 510_4925.2ip 22MB  100% [22 MB) 018 7116/20
P  510_4926.2ip 23.7MB  100% [23.7 MB] 0j28 7/16{20
® Video <7 510_4927.2ip | 24.7 B | 100% [24.7 MB] | |ojis | | 7/16/20
=21 Filters ¥ 510_4928.2ip 24,9MB  100% [24.9 MB] 019 7/16/20
+ Complete + 510_4929.zip 25.2MB  100% [25.2 MB] 0/18 7/16{20
 Inprogress ¥ 510_4930.2ip 25.8MB  100% [25.8 MB) 0j17 7/16/20
Stopped + 510_4931.zip 27MB  100% [27 MB] 0/18 7116/20
Scheduled ¥ 510_4932.2p 26.7MB  100% [26.7 ME] oj1a 7/16/20
T "'smlry ) ¥ 510_4933.2ip 26.6MB  100% [26.6 MB) 018 7116/20
Az Recycls B  510_4934.zip 14.3MB  100% [14.3 MB] 0/13 7/16{20
15BMapServlet_Link. oj0 0Bfs 7i16j20
15BMapServlet_Link ofo 7H620
15BMapServlet_Link ofo 71620
>
Log | B Progress § Media preview/convert Opinions
Time: Date Information o
« 5:22:10 ... 7/16{2009  [Section 16] - Done
# 5:22:10 ... 7/16/2009  Creating new section...
» 5:22:10 ... 7/16/2009  Cancelled
« 5:22:10 ... 7/16{2009  [Section 18] - Done
# 5:22:10 ... 7/16/2009  Creating new section...
» 5:22:10 ... 7/16/2009  Cancelled
¥ 5:23:23 ... 7/16/2009  [Section 10] - Stopped
¥ 5:123:23 ... 7/16/2009  Stopped
@ 5:23:30 ... 7/16/2009  Starting download...
# 5:23:30 ... 7/16/2009  Opening file on the disk...
¥ 5:23:30 ... 7/16/2009  Succeeded
¥ 5:23:30 ... 7/16/2009  [Section 10] - Started
» 5:123:30 ... 7/16/2009  [Section 10] - Downloading
+ 5:23:30 ... 7/16/2009  [Section 10] - Done
< s ¥ 52330 .. 7/16/2009  Download complete v
Ready 498 MB; 0 B 0B/s; 0Bfs ( i) Freel

If downloads get stuck, they can be stopped and restarted in a similar manner to

dTa as discussed above.
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